seclan のほえほえルーム

| |

xrea の旧サーバでも php5 が利用可能に!

・
2006/11/16 []

番号が古い xrea のサーバでは、モジュール版の php4 と cgi 版の php4 のみが提供されていました。それに対し、番号が三桁付近とそれ以降のサーバでは、モジュール版 php4 または php5 のどちらかと、cgi 版の php4 と php5 の両方が提供されてきました。つまり番号が古い xrea サーバでは php5 を使用することができなかったのです。そのため新しい機能、例えば sqlite などの機能を使用することができませんでした。

しかし先日調べたところ、旧サーバにもいつの間にか php5 の cgi 版がインストールされており、利用可能な状態になっていました。インストールは八月の下旬に行われたようです。そこで php5 から標準で利用可能になっている sqlite が組み込まれているかどうか調べてみたところ、sqlite2 が利用可能になっていることを確認しました。これで MySQL や PostgreSQL のほかに、SQLite が利用可能になりました。

また php5 では、デーベース操作の関数として新たに PDO クラスが提供され、このクラスを通して操作することで、各データベースを共通に利用することができるようになります。そして、php5 ではこの PDO を通して SQLite3 が利用可能になっています。そこで、PDO ではどのデータベースが利用可能になっているか、調べてみたところ、mysql、pgsql、sqlite2 が利用可能になっているようです...。って、sqlite3 が入ってないよ!と言うわけで、現在のところ sqlite3 は使用できず、sqlite2 が、sqlite2 の API と PDO を通して利用可能になっていることがわかりました。



by seclan | コメント (0) | トラックバック (0)

関連

コメント

 コメントできる期間はすでに過ぎています。


トラックバック

 トラックバックできる期間はすでに過ぎています。


| |

 

配信

26.24 msec